Jump to content

Erreur syntax 'DEFAULT CHARSET=latin1'


bird71

Recommended Posts

Bonjour

voilà, j'essaie d'installer un script et sa base sql et j'ai un message d'erreur dans phpmysql:

en bas de la table...

...

PRIMARY KEY ( `ad_id` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

MySQL a répondu:

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 25

Je l'avais installé sans problème sur un autre hébergement mais là ça ne va pas! est-ce du à la version php (4) ? y a t'il quelque chose à changer? Difficile de trouver dans la doc mysql pour quelqu'un qui n'y comprend pas gd chose..?? :whistling:

Si quelqu'un peut m'eclairer? merci

:)

Link to comment
Share on other sites

voilà, j'essaie d'installer un script et sa base sql et j'ai un message d'erreur dans phpmysql:

en bas de la table...

Peux-tu nous dire dans quel environnement, cela se produit-il (en local, hébergeur...) ?

xpatval

Link to comment
Share on other sites

C'est chez un hébergeur!

Avec l'installation automatique via le script, ça met un message du style 'connection avec la base' mais ça en reste là... impossible de passer à l'étape suivante!

En la créant via phpmysql, ça me met le message avec cette erreur!!

J'ai essayé de changer la terminaison latin1.. mais ça ne change rien! :nonono::blush:

Link to comment
Share on other sites

En effet ça doit venir de ça!

En exportant la base depuis l'hébergement où elle fonctionne et en la re-important, les erreurs disparaissent!! En regardant le fichier, les fins de tables sont bien modifiées...!

Seul hic, ça me crée des problèmes au niveau des fichiers config, l'installation auto ne fonctionne pas et elle devait créer un répertoire config complet, pour l'instant je bloque la dessus, mais ça doit pouvoir se régler en regardant plus en détails...

Merci pour la piste...!

;)

Link to comment
Share on other sites

  • 6 months later...

désolé de répondre comme ça à un thread de 6 mois mais je voulais donner l'info que pour pallier à ce genre de problème (transfert d'une base de données d'un serveur MySQL récent à un serveur MySQL ancien) il suffit d'utiliser l'outil mysqldump (gratuit et installé avec Mysql : l'executable mysqldump.exe se trouve d'ailleur dans le même répertoireque mysql.exe) on l'utilise en lancant la commande suivante sous msdos :

mysqldump --user=login --password=mot_de_passe --host=adresse_ip_de_l_hote --compatible=mysql40 > backup.sql

dans les parametres "--compatible=mysql40" veut dire que on va rendre le fichier bacup.sql compatible avec les vieilles versions mysql 4.0 en fait la ligne de commande crée un fichier backup.sql dans le répertoire ou se trouve mysqldump.exe ce fichier s'utilise comme les fichier de sauvegarde fait par PHPMyAdmin (je me demande même si PHPMyAdmin ne se sert pas en fait de ce programme pour faire les backup mais j'ai la flème de mater le code source de PHPMyAdmin)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...