Aller au contenu
Mado

site de tableau en vente ou location en ligne

Noter ce sujet :

Recommended Posts

merci Dan et bonjour

bon... j'ai cette erreur mais je ne sait pas ce que ca veut dire quand je remplis le formulaire :unsure:

You have an error in your SQL syntax near 'artiste","xxc","xcxcx","xcxcx","xcxcx","xcxc","xcxc","cxxc","xcxc","xcxc","xcxc"' at line 1

merci

Modifié par mariepetroni

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

dans la synthaxe de ta requète, tu mets tantôt des simples quotes, tantôt des doubles quotes. Il faut mettre des simple quote partout.

Pour la requète

'artiste","xxc","xcxcx","xcxcx","xcxcx","xcxc","xcxc","cxxc","xcxc","xcxc","xcxc"'

tu aurais dû écrire :

'artiste','xxc','xcxcx','xcxcx','xcxcx','xcxc','xcxc',etc....

A+.

Partager ce message


Lien à poster
Partager sur d’autres sites

Marie,

Dans la requête se trouvant dans la source que tu m'as envoyée, tu avais des erreurs de simples/doubles quotes. Certaines manquaient tout simplement, d'autres étaient inversées. :(

Tu as mal copié le code plus haut ...

Essayes en remplaçant ta ligne par:

$query='INSERT INTO membre (statut,pseudo,nom,prenom,societe,
adresse,code postal,ville,telephone,mail,mot de passe)
VALUES ("'".$statut."','".$pseudo."','".$nom_membre."','".$prenom_membre."','".
$societe_membre."','".$adresse_membre."','".$cp_membre."','".$ville_membre.
"','".$tel_membre."','".$mail_membre."','".$mdp_membre."')";

Dan

PS: il faut que ... (enlèves les espaces rajoutés pour que ce soit plus lisible)

- devant la première variable tu aies la chaîne "VALUES ( ' ".

- entre les variables, tu aies: ." ' , ' ".

- et à la fin ... ." ' ) " ;

Fais du copier/coller sinon tu vas encore une fois te louper sur ce coup là ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

ben ca marche po

faut pas ajouter avant statut un zone vide pour que l'id s'autoincremente?

Partager ce message


Lien à poster
Partager sur d’autres sites
Ca parait juste, seulement, il y a 3,5 lignes de répétitions. Tu peux faire ceci :

A+, Anonymus.

Anonymus

ca marche pas ca revient a la page index.php3

par contre si je mets $url=memb_connect ca marche

c'est juste ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu peux poster le code que tu as essayé, stp ?

Partager ce message


Lien à poster
Partager sur d’autres sites

celui la il est un peu plus haut ;)

$url=$memb_connect;

if($statut=="artiste")$url=$memb_connect_art;

echo "<meta http-equiv='refresh' content='5;URL=".$url."?id=$id_membre'>";

echo "<font size='2'>Merci, vous êtes bien enregistré.";

echo" Vous avez recu un mail de confirmation avec vos données personnelles. ";

echo"Vous allez etre redirigé dans 5 seconde vers votre partie Membre, sinon Cliquez ";

echo"<a href=\"".$url."id=$id_membre\">ici</a></font>";

Partager ce message


Lien à poster
Partager sur d’autres sites
Anonymus

ca marche pas ca revient a la page index.php3

par contre si je mets $url=memb_connect ca marche

c'est juste ?

Tu dis

Où mets tu $url=memb_connect ?

Anonymus.

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai efface le srcipt complet

ca a encore changé mais ca marche toujours pas :wacko:

Modifié par mariepetroni

Partager ce message


Lien à poster
Partager sur d’autres sites
Marie,

$query='INSERT INTO membre (statut,pseudo,nom,prenom,societe,
adresse,code postal,ville,telephone,mail,mot de passe)
VALUES ("'".$statut."','".$pseudo."','".$nom_membre."','".$prenom_membre."','".
$societe_membre."','".$adresse_membre."','".$cp_membre."','".$ville_membre.
"','".$tel_membre."','".$mail_membre."','".$mdp_membre."')";

Dan

si je mets ca il me met un message d'erreur parse error en ligne 92 c'est la ligne ou j'ai fait le copier coller

avant insert c'est pas une double quote et avant statut y'a pas une double quote en trop?

si je mets ca

// Insertion dans la table

$query="INSERT INTO membre (statut,pseudo,nom,prenom,societe,

adresse,code postal,ville,telephone,mail,mot de passe)

VALUES ('".$statut."','".$pseudo."','".$nom_membre."','".$prenom_membre."','".

$societe_membre."','".$adresse_membre."','".$cp_membre."','".$ville_membre.

"','".$tel_membre."','".$mail_membre."','".$mdp_membre."')";

$result=mysql_query($query) or die (mysql_error());

et que je remplis les champs du formulaire apres validation j'ai le message d'erreur suivant

You have an error in your SQL syntax near 'postal,ville,telephone,mail,mot de passe) VALUES ('artiste','cc','cc','cc','cc'' at line 2

bé ca marche pas

:?:

Modifié par mariepetroni

Partager ce message


Lien à poster
Partager sur d’autres sites

$url=$memb_connect;

if($statut=="artiste")$url=$memb_connect_art;

echo "<meta http-equiv='refresh' content='5;URL=".$url."?id=$id_membre'>";

echo "<font size='2'>Merci, vous êtes bien enregistré.";

echo" Vous avez recu un mail de confirmation avec vos données personnelles. ";

echo"Vous allez etre redirigé dans 5 seconde vers votre partie Membre, sinon Cliquez ";

echo"<a href=\"".$url."id=$id_membre\">ici</a></font>";

comment sait (on que $memb_connect renvoie a la page memb_connect.php3

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu dois avoir, avant la phrase que tu as mis en gras, une ligne qui dit :

$memb_connect="memb_connect.php3";

Ce peut etre dans un autre fichier, mais forcément avant cette ligne.

Il devrait y avoir, au meme endroit, une ligne qui dit

$memb_connect_art="*****";

Les ***** sont le nom de fichier qui correspond à $memb_connect_art.

Un conseil

Mets des pointeurs, des espions :

Quand tu vois qu'un script comme celui ci ne marche pas, fais ceci :

Le script qui ne marche pas :

$url=$memb_connect;

if($statut=="artiste")$url=$memb_connect_art;

echo "<meta http-equiv='refresh' content='5;URL=".$url."?id=$id_membre'>";

echo "<font size='2'>Merci, vous êtes bien enregistré.";

echo" Vous avez recu un mail de confirmation avec vos données personnelles. ";

echo"Vous allez etre redirigé dans 5 seconde vers votre partie Membre, sinon Cliquez ";

echo"<a href=\"".$url."id=$id_membre\">ici</a></font>";

Ajouter des marqueurs :

echo "<br>statut == $statut";

echo"<br> memb_connect == $memb_connect";

echo"<br> memb_connect_art == $memb_connect_art";

$url=$memb_connect;

if($statut=="artiste")$url=$memb_connect_art;

echo"<br> url == $url <br>";

/*

echo "<meta http-equiv='refresh' content='5;URL=".$url."?id=$id_membre'>";

echo "<font size='2'>Merci, vous êtes bien enregistré.";

echo" Vous avez recu un mail de confirmation avec vos données personnelles. ";

echo"Vous allez etre redirigé dans 5 seconde vers votre partie Membre, sinon Cliquez ";

echo"<a href=\"".$url."id=$id_membre\">ici</a></font>";

*/

Ceci te permet de connaitre l'état de tes variables, si elles sont initialisées, si elles renvoient la bonne valeur, etc, etc.

Tu peux faire pareil avec les requetes de bases de données.

A+, Anonymus.

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai interogé la base pour voir si je recupere l'id ca ma met "impossible d'afficher les resultats

j'ai fait cette page

apparement la ou je met id=$id_membre j'ai un message d'erreur qui dit qu'il ne connait pas id

<?

require("conf.php3");

// CONNEXION MYSQL

$db = mysql_connect($sql_serveur,$sql_user,$sql_passwd);

if(!$db) {echo "Connexion impossible à la base de données <b>$sql_bdd</b> sur le serveur <b>$sql_server</b><br>Vérifiez les paramètres du fichier conf.php3"; exit;}

$query =mysql_db_query($sql_bdd,"select * from membre where id_membre='$id_membre'",$db) or die(mysql_error());

$query_result = mysql_query($query);

if (!$query_result) {

echo ("Impossible d'afficher les résultats");

} else {

echo ("Voici les résultats");

// Traitements

}

?>

suis desolée avec tout mes probs php, si je vous tanne , suffit de le dire ;)

merci Anonymus ca marche ton astuce de marqueurs sauf pour id :shutup:

Partager ce message


Lien à poster
Partager sur d’autres sites

bonsoir,

dans cette table on a statut, qui dans la bdd est toujurs a 0

pourtant j'ai deux choix... artiste et autre... comment vais je pouvoir sortir tous les membres qui sont artistes ou tous les membres qui sont autre ainsi?

et puis je ne parviens pas a recuperer l'id membre dans la page profil

vous pouvez m'expliquer pourquoi? ;) ?

merci

CREATE TABLE membre (

id_membre int(10) unsigned NOT NULL auto_increment,

statut tinyint(10) NOT NULL DEFAULT '0' ,

pseudo char(10) NOT NULL DEFAULT '' ,

nom_membre char(10) NOT NULL DEFAULT '' ,

prenom_membre char(10) NOT NULL DEFAULT '' ,

societe_membre char(10) NOT NULL DEFAULT '' ,

adresse_memre char(10) NOT NULL DEFAULT '' ,

cp_membre char(10) NOT NULL DEFAULT '' ,

ville_membre char(10) NOT NULL DEFAULT '' ,

tel_membre char(10) NOT NULL DEFAULT '' ,

mail_membre char(10) NOT NULL DEFAULT '' ,

mdp_membre char(10) NOT NULL DEFAULT '' ,

site_membre char(100) NOT NULL DEFAULT '' ,

PRIMARY KEY (id_membre),

UNIQUE id_membre (id_membre),

INDEX id_membre_2 (id_membre)

);

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

Pour ce qui est du '0' que tu vois dans la base :

statut tinyint(10) NOT NULL DEFAULT '0' ,

cela signifie : le champ 'statut' est de type tinyint (autrement dit un petit 'integer'), qui est non null (autrement dit : il a forcément une valeur), et par défaut, il est à '0' (autrement dit : si tu ne rentres pas de valeurs pour lui, il se met automatiquement à zero).

Tu devrais voir si, lorsque tu fait INSERT INTO MEMBRE, le chiffre que tu inseres est bien entré dans la base. Apparemment, il a autre chose qu'un chiffre, et c'est pour ca qu'il ne peut rentrer de valeurs, et donc c'est pour ca qu'il te met automatiquement zero.

Pour ce qui est de l'id membre, il s'agit probablement d'une erreur de syntaxe. Vérifies bien la facon dont tu l'écris, d'une part du coté de la requète, et d'autre part, du coté de la table (le champ id membre s'ecrit il id membre, ou id_membre, ou id-membre, ou id_menbre, etc....)

apparemment, ca viendrait de cela.

Anonymus.

Partager ce message


Lien à poster
Partager sur d’autres sites

oui, mais ca valeur est toujours a zero dans la base donc je ne peux pas faire de trie sur le statut, puisque que j'ai rien dans la base qui dit que tel membre est artiste ou autre... j'ai juste?

merci anonymus, mais j'insere pasde chiffre ... je comprends pas la.. dans le formulaire j'ai bouton radio statut value artiste et l'autre value autre

si je mets pas ca comment ca marcherait avec la redirection en fonction du statut... tu m'avais corrigé ce que j'avais ecrit avec le $memb_connect etc...

if statut==artiste

faut bien que artiste soit mentionné quelque part nan?

j'ai vraiment du mal a comprendre...

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

bon , ben merci

je dois rendre mon projet pour mercredi alors j'abandonne le reste que je voulais faire

j'aurais juste la page de membre, meme si ca marche pas bien, c'est deja ca ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×