Jump to content
Sign in to follow this  
PhantomJoey

chemin .htaccess

Rate this topic

Recommended Posts

Bonjour à tous,

Je fais des essais de mon morceau de site et j'ai un problème :huh: avec le chemin dans le fichier .htaccess.

Normalement on doit mettre le chemin en dur du .htpasswd mais comment fais-t on une fois sur le server ? :?:

Car j'en ai essayé pas mal : avec localhost pour remplacer ce qui précède le répertoire de mon site ( tout ce qui se trouve avant le répertoire de mon site je n'y ait pas access ce qui est normal je pense), j'ai essayer avec l'adresse du server et evec une adresse relative.

Je ne sais plus quoi essayer :evil:

Merci d'avance

Share this post


Link to post
Share on other sites

Bonjour,

Imagines que ton fichier htaccess soit dans le répertoire :

/principal/image/.htaccess

Pour avoir accès au répertoire /principal, il y a deux solutions :

- Soit tu mets son url 'absolue',

- soit tu mets son url relative.

Chemin absolu :

http://www.mangeur-de-cigogne.org/

chemin relatif :

../fichier.html.

Tu remarqueras les 2 points : .. avant le slash : /

Ces deux points ( ../ )veulent dire : remonter d'un niveau dans l'arborescence du répertoire, au meme titre que le point tout seul ( ./ ) veut dire : rester dans le même répertoire.

Donc, il te suffit de mettre une url relative (relative à la position du fichier htaccess), et de mettre 2 points et un slash, soit ../ pour indiquer que tu désires remonter d'un niveau.

A+, Anonymus.

ps : le lien n'ayant Que valeur d'exemple ;)

Share this post


Link to post
Share on other sites

J'ai essayé une adresse relative mais sans succès. :huh:

pourtant ça parait simple je dois seulement rentrer dans un répertoire sans remonter dans l'arborescence.

soit:

"./monrepertoire/.monhtpasswd"

j'ai même essayé:

"/monrepertoire/.monhtpasswd"

sans le point ça ne marche pas non plus. :blink:

Puis je mettre mon .htpasswd dans le même repertoire que mon .htaccess sans risque pour la sécurité ou de conflit quelconque? :?:

Share this post


Link to post
Share on other sites

Bonjour PhantomJoey,

Il te faut un chemin serveur complet (full path) ...

Pour connaître ce chemin serveur (que ton hébergeur a normalement dû te donner), tu as une possibilité simple, un script php d'une ligne:

<?php
echo $_SERVER['DOCUMENT_ROOT'];
?>

Ceci te donnera le chemin de la racine de ton site. Il te suffira d'ajouter à la fin de cette valeur les sous-répertoires jusqu'au fichier .htpasswd

;) Dan

Share this post


Link to post
Share on other sites

Bon ça ne doit pas être un pb de chemin puisque qu'il ne reconnait toujours pas le login/passwd que j'ai entré dans le fichier .htpasswd. :wacko:

Faut-il obligatoirement crypter le mot de passe pour que le .htaccess fonctionne ? :?:

Car je n'ai pas crypté le mot de passe peut-être que le pb vient de là ? :?::?:

Share this post


Link to post
Share on other sites

Salut PhantomJoey,

Il faut encrypter le mot de passe, sauf chez Free et Online qui ont leur procédure expliquée et utilisent une autre approche.

Pour l'encrypter, vas voir l'article sur le fichier .htaccess dans les publications du Hub.

Tu y trouveras un formulaire de saisie te permettant d'encrypter le mot de passe, dans le tiers inférieur de la page.

Cordialement,

Dan

Share this post


Link to post
Share on other sites

Merci beaucoup Dan,

je vais aller m'informer toujours et encore c'est ce que j'aime dans l'informatique: :wub: il est impossible de tout savoir il faut toujours apprendre ...........

Et "dieu sait" que je suis seulement débutant et que je ne peux qu'apprendre.

Bref j'y vais.

Share this post


Link to post
Share on other sites

Bon eh bien j'ai crypté mes mot de passe mais cela ne marche toujours pas.

Alors qu'en local cela marchait très bien je ne comprend vraiment pas :huh::o:blink::(

J'avoue que je suis perdu.

Bon je vais continuer de chercher jusqu'à que je trouve, après tout ce n'est pas un fichier .htaccess/.htpasswd qui va me tenir tête. :evil:

Merci à tous d'avoir essayer de m'aider, si vous avez d'autres idées je suis toujours preneur. :up:

Share this post


Link to post
Share on other sites

Rebonjour tout le hub,

Je récapitule mon pb:

j'ai créé des fichiers .htaccess et .htpasswd pour sécuriser un répertoire et la boite de dialogue s'ouvre mais les login/mot de passe ne sont pas reconnus. :huh:

Qu'est-ce que je pourrai faire pour résoudre ce problème ? :?:

Share this post


Link to post
Share on other sites

PhantomJoey,

Pourrais-tu nous donner le contenu de ton fichier .htaccess, ainsi que la valeur de la variable $_SERVER['DOCUMENT_ROOT'] (voir plus haut) ?

Et tant qu'on y est, le nom de ton hébergeur... le répertoire et le contenu du fichier .htpasswd (le mot de passe est encrypté... mets des xxx à la place du nom)

Dan

Share this post


Link to post
Share on other sites

Dan j'ai fait une gaffe j'ai laissé mon nom d'utilisateur et le site pourrais-tu effacer mon message..........;

Share this post


Link to post
Share on other sites

J'ai effacé le message. Envoies le à Dan, par MP, ce sera plus simple.

A+.

Share this post


Link to post
Share on other sites

Merci beacoup pour avoir rectifié ma gaffe,

Voici les infos:

contenu du .htaccess:

AuthType Basic
AuthName "Acces Restreint"
AuthUserFile "/home/MonNomUtilisateur/MonSite.com/public_html/HTAccess/.htpasswd"
AuthGroupFile /dev/null
<Limit GET POST>
require valid-user
</Limit>

valeur de $_SERVER['DOCUMENT_ROOT'] :

"/home/MonNomUtilisateur/MonSite.com/public_html/"

mon hébergeur est : support.yourwebhosting.com

chemin du .htpasswd par rapport à mes pages est : "/HTAccess/.htpasswd"

contenu du htpasswd:

xxxxx:22kNGGT5K
xxxxx:f42156avZX
xxxxxx:91hYrMA5i

Voilà j'espère que vous pourrez m'aider

Encore merci

Share this post


Link to post
Share on other sites

Bonjour à tous,

Ca y est j'ai enfin trouvé :idea: et j'avoue que c'était une erreur bête puisque c'était à

cause d'un répertoire oublié dans le chemin(je suis vraiement honteux :blush: ).

Veuillez m'excusez de vous avoir fait chercher pour rien, quoique j'ai quand même appris des :flower: choses sur les chemin dans l'.htaccess.

Encore Merci à tous.

Share this post


Link to post
Share on other sites

Salut PhantomJoey,

La seule chose qui diffère avec les fichiers que je mets généralement en place sont les guillemets autour du chemin du fichier .htpasswd mais je viens de faire un test et ca ne change rien....

Reste 3 possibilités:

  • Apache n'a pas les permissions pour lire le fichier .htpasswd (s'il est mis en mode 0600 ou 0640 par exemple ou que les permissions du répertoire sont trop restrictives) ... essayes en mettant le fichier en mode 0666 et le répertoire /HTAccess/ en mode 755. On verra pus tard pour limiter les permissions progressivement.
  • L'encryptage n'est pas bon... en es-tu sûr ? Si tu as utilisé le formulaire de l'article il devrait être bon.
  • Les fichiers ont été édités sous Windows/Mac et transférés en mode binaire ftp au lieu de ASCII... ils pourraient donc contenir des caractères "exotiques" (fins de lignes non-unix)

Dan

Share this post


Link to post
Share on other sites
Veuillez m'excusez de vous avoir fait chercher pour rien, quoique j'ai quand même appris des  :flower: choses sur les chemin dans l'.htaccess.

Faut pas s'excuser, ca nous a fait un peu d'exercice mental ;)

Heureux de voir que ca fonctionne tout de même... je commencais à douter :lol:

Dan

Share this post


Link to post
Share on other sites

Eh bien moi aussi je suis rassuré :lol:

Et c'est le moment que je préfère en info c'est lorsqu'après avoir bien cherché tu trouve: ça fait du bien nerveusement et psychologiquement. B)

Encore merci

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By cyberdede
      Bonjour à tous

      je voudrais quand je tape https;//monsite/dossier accéder à https;//monsite/dossier/index.php
      or j'accède à https;//monsite/dossier/ avec un 404

      en localhost ca fonctionne

      pour la racine https;//monsite c'est ok

      mon htaccess
       
      RewriteEngine On Options -Indexes RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^([^\.]+)$ $1.php [NC,L] RewriteCond %{HTTPS} ^off$ [NC] RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L] AddDefaultCharset UTF-8 ErrorDocument 404 /404.php  
    • By kevinjoseph
      Bonjour, j’ai un gros problème sur mon site Wordpress . Du jour au lendemain, mon site wordpress fais une redirection vers un autre site wordpress que j’ai crée ,sans que je touche à quoi que ce soit. Quand j’essai d’aller sur l’admin pour désactiver les plugins et voir d’où peut venir le problème. Impossible d’accéder, sa me redirige vers l’admin de l’autre site. Au final il est impossible que j’accède au site via (google, la bare de recherche, les favoris, l’admin…) pour voir ce qu’il fonction pas, j’ai juste accès au FTP. J'ai essayé de voir d'où pouvez venir ce bug en supprimant les plugins, le théme, mes derniers modifications, regarder sur le .htaccess si il y avais quelque par le nom de domaine de l'autre site écrit. Ca n'a rien changer, le site continue de ce rediriger automatiquement vers l'autre site. Si vous avez une idée d’où sa peut venir ou comment faire pour arranger ça et surtout comment éviter que sa ce reproduise. Sa m’aiderai beaucoup, merci d’avance.
      voici le code du .htaccess:
       
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

      # END WordPress
      ~   Ludovic • 16:28    
    • By leobk
      Bonjour,
       
      J'ai un sous-domaine www.fr.monsite.com dédié pour la réservation des vols
      j'ai redirigé récemment ce sous-domaine vers le site principal www.monsite.com et le nombre des erreurs 404 a explosé
      un nombre énorme d'URLs de type :
      www.fr.monsite.com/fr/vols/index?f_type=01&f_departure=TLS&f_destination=DJE&f_date_from=08/09/2013&f_date_to=22/09/2013&f_flexibility=3&f_paxs_adults=2&f_paxs_childs=0&f_paxs_infants=0
      redirigent vers :
      www.monsite.com/fr/vols/index?f_type=01&f_departure=TLS&f_destination=DJE&f_date_from=08/09/2013&f_date_to=22/09/2013&f_flexibility=3&f_paxs_adults=2&f_paxs_childs=0&f_paxs_infants=0
       
      L'URL de destination est biensur introuvable 404, puisque les variables utilisés dans les deux sites ne sont pas identiques
      Voici la structure d'URL si on fait une recherche de vol sur le site principal :
      https://www.monsite.com/fr/resa?depart=SXF&arrivee=NBE&aller=2017-11-10&retour=2017-11-30&adultes=1&enfants=1&bebes=0&departureDateTime_D=&arrivalDateTime_D=&departureDateTime_R=&arrivalDateTime_R=&fareGroupName=&fareGroupName_R=&sens=2&currency=EUR&airline=&flightNumber=&flight=&flight_retour=&webview=0&felxibilite=2
       
       
      existe-il un moyen pour rediriger l'ensemble des URLs dynamiques du sous-domaines vers une URL statique du domaine principale (autre que l'accueil)?
       
       
    • By PieceMobile
      Bonjour,



      J'espère que vous allez tous bien.



      Auriez vous une solution pour rediriger ( via une règle htaccess par exemple ) :



      http://www.mon-site.com/blabla.html?ps_mobile_site=1



      vers : http://www.mon-site.com/blabla.html



      A mon avis, s'agissant d'un paramètre d'URL, de ce que j'ai cru comprendre -a mon petit niveau- c’était pas possible, mais ça me dépannerai pas mal si l'un d'entre vous avait une idée.



      Merci d'avance





×
×
  • Create New...