Jump to content
Sign in to follow this  
nolog

php login dynamique

Rate this topic

Recommended Posts

j'arrive a transmettre le nom par URL mais pour la verification du pass

j'ai un souci voila mon script si quelqu'un peut m'eclairer merci beaucoup

<?php

if ($HTTP_POST_VARS['valider']=="ok")

{

$pass=$_post['pass'];

if(strlen($_post['pass'])>0)

{

switch ($pass)

{

case $row_rsinitfiche['pass']:

header (location:"modifier.php");

break;

default:

echo "mot de passe erroné";

break;

}

}

}

?> :blink:

Share this post


Link to post
Share on other sites

Bonjour,

Dans ton script tu utilises indifférement $HTTP_POST_VARS et $_POST (attention aux majuscules).

Il ne me semble pas que tu peux utiliser les deux à la fois... Cela dépend de la configuration et de la version de PHP.

Essaye avec $_POST et tiens nous au courant. :)

PS : utilise les balises

 pour poster ton code, ca aide à la lisibilité.

Share this post


Link to post
Share on other sites

merci norseb

avec la correction des majuscules c'est mieux mais maintenant dès que je tape le mot de passe les deux champs se vident et je reste tjs sur la meme page!!

alors que normalement ca devait fonctionner comme suite

le client qui souhaite changer ses données clique sur "modifier"

la il arrive sur une page login ou son nom est passe par url

il doit juste tapez son mot de passe pour acceder a la page modifier.php

Share this post


Link to post
Share on other sites

Et pourquoi ne pas utiliser les variables de SESSION ?

Tu met son login ou son id dans la session et tu fais un update du password pour l'id que tu as en SESSION

Share this post


Link to post
Share on other sites

bonjour;

pour proteger un repertoire par login mdp, je cree un formilaire dans lequel j'insere un tab (login:champ de texte, mdp:champ de texte, bouton:valider)

j'ai le script suivant, apres mon formulaire:

<?php 
if ($HTTP_POST_VARS['valider']=="ok")
{
if (($HTTP_POST_VARS['login']=="toto") AND ($HTTP_POST_VARS['pass'])=="aaa")
{
header("location:gerer_evenement.php");
}else {
 $erreurlog=1;
 }
}
?>

mais des que saisie "toto","aaa"

je reste ala meme page avec le message d'erreur:

Warning: Cannot modify header information - headers already sent by (output started at c:\sites\music\admin\login.php:6) in c:\sites\music\admin\login.php on line 49

une reponse de votre part m'aiderai beaucoup

Share this post


Link to post
Share on other sites

C'est parce que ton fichier a déjà envoyé ne fût-ce qu'un caractère au navigateur avant l'appel à la fonction header().

Vérifie que tu n'as pas laissé par exemple une ligne blanche au dessus de ton code php. Il faut que ce code vienne tout au début de ta page.

Dan

Share this post


Link to post
Share on other sites

:hourra: super gentil, merci enormement ca marche !

je n'avais pas placé le script au debut de ma page.

j'aurai une deuxieme question si cela ne te derange pas

concernant la protection d'acces avec .htacess

il faut le placer ou ce dernier par rapport au repertoire ou la page a proteger? :blush:

:hourra:

Share this post


Link to post
Share on other sites

Tu le places où tu veux, mais de préférence dans le répertoire qui contient la page.

Et pour le fichier mot de passe, tu peux le mettre hors de l'espace web... c'est plus "sûr".

Vas voir l'article sur le Hub: Le fichier .htaccess

Dan

Share this post


Link to post
Share on other sites

je l'ai lu ce tuto et son premier cours sur .htaccess

j'"essaye de l'appliquer:

j'ai donc mis unfichier.htaccess dans mon repertoire /admin

AuthUserFile   /home/login/sites/restreint/.htpasswd
AuthGroupFile /dev/null
AuthName "Espace Administrateur"
AuthType Basic
<Limit GET POST>
require valid-user
</Limit>

mais quand je verifie en local si mon repertoire demande un login mdp

ce n'est pas le cas

est ce que je dois créer une page index dans le repertoire admin qui contient un formulaire login mdp? ou ca dois ce faire automatiquement avec .htaccess?

et pour .htpasswd, malgré le fait que j'ai enlevé l'extention .rtf avec mon ftp des que je fais couper/coller dans sites/restreint/:il me la remet?est ce normal

merci d'avance de m'aider

Share this post


Link to post
Share on other sites

Non, ce n'est pas normal. Le fichier doit porter le nom que tu auras défini dans la directive AuthUserFile du fichier .htaccess

S'il te rajoute l'extension .rtf, j'imagine que tu es sous Windows, et dans ce cas le chemin /home/login/sites/restreint/.htpasswd ne sera pas bon...

C'est toujours le problème des fichiers .htaccess en utilisation locale si on n'est pas sous Linux.

Assures-toi aussi que le fichier soit bien au format "texte seul" ... sans les sauts de ligne générés par Word ou tout autre traitement de texte. Le mieux est d'utiliser "notepad.exe", et penser à l'envoyer par ftp en mode "ASCII" et non pas en mode "BINARY".

Share this post


Link to post
Share on other sites

En fait je travail sous dreamweaver et j'ai installé wamp5 en localhost

je viens de reécrire les fichiers .htaccess (dans dreamweaver j'arrive a enlever l'extension) mais pour .htpasswd il prend l'extension .txt!!

est ce que l'invitation de la fenetre login mdp se fait automatiquement sinon?

Share this post


Link to post
Share on other sites

du fait que je suis sous windows ,ca ne marcherais pas le protection de mon repertoire??

Share this post


Link to post
Share on other sites

je suis sous windows xp et je teste en local avec wamp5

j'ai du changer dans httpd.conf

AllowOverride (none) en (all)

et apres creation de .htaccess et .htpasswd

j'arrive a voir la fenetre d'identification

mais quand je saisie le login et le mot de passe je ne parviens pas a acceder au repertoire!!

AuthName "zone réservée"
AuthType Basic
AuthUserFile "c:\wamp\apache\.htpasswd"
require user adil dam

pour le .htpasswd

il prend toujours l'extension .txt dans c:\wamp\apache\

est ce acause de ca que ca bloque??

si un initié peut me filer un coup de main ca serai sympa

Share this post


Link to post
Share on other sites

Crée le fichier au départ de DreamWeaver... enregistre-le et nomme-le .htpasswd.

C'est windows XP qui rajoute une extension, et c'est à cause de cette extension en .txt que cela ne marche pas.

Share this post


Link to post
Share on other sites

le s fichiers .htaccess et .htpasswd kje les creent avec le bloc note en suite le htaccess comme il dans le repertoire du site sous dream came permt de changer l'extention (enlever le .txt) mais pour le .htpasswd comme il est en dehors de dreamweaver je n'arrive pas a enlever l'extention.txt al'aide

Share this post


Link to post
Share on other sites

sous windows, dans les options de la fenetre, tu peux (si mes souvenirs sont bons... je ne suis pas sous Windows donc, je ne peux te le certifier) choisir d'afficher les extensions. Tu affiches les extensions et tu renome ton fichier en virant le .txt ;)

Share this post


Link to post
Share on other sites
le s fichiers .htaccess et .htpasswd kje les creent avec le bloc note en suite le htaccess comme il dans le repertoire du site sous dream came permt de changer l'extention (enlever le .txt) mais pour le .htpasswd comme il est en dehors de dreamweaver je n'arrive pas a enlever l'extention.txt al'aide

Merci de rédiger en français correct !

Crée le fichier au départ de DreamWeaver... enregistre-le et nomme-le .htpasswd.

C'est windows XP qui rajoute une extension, et c'est à cause de cette extension en .txt que cela ne marche pas.

Je t'ai dit de le faire au départ de Dreamweaver !

Share this post


Link to post
Share on other sites
Supprimer l'extension .txt ;)

Pour que ton fichier fonctionne, il faut que le fichier se nomme .htaccess et non .htaccess.txt ;)

<{POST_SNAPBACK}>

Tu peux changer l'extension avec ton client ftp préféré.

- Tu upload ton fichier

- ensuite tu le renome

Hervé

Share this post


Link to post
Share on other sites

j'ai fini par trouver comment afficher les extensions mais des que j'enleve le point txt j'ai le message:

vous devez specifier un nom de fichier

j'arrive a effacer le .txt seulement si j'enleve le point du " ."htpasswd

aidez moi svp

Share this post


Link to post
Share on other sites

au depart de dreameaver ca serait sympa de prciser car moi je ne vois pas ce que tu veux dire par la!!

Share this post


Link to post
Share on other sites

Tu ouvres dreamweaver, cliques (clic-droit) sur le nom du fichier .htpasswd dans la liste des fichiers du site, et choisis "renommer". Là tu pourras le renommer sans l'extension .txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...