Jump to content
Sign in to follow this  
Tutur

Problème d'enregistrement SOA

Rate this topic

Recommended Posts

Bonjour à tous,

Je dispose d'un serveur dédiée, avec Debian 6.0.5 en 64bits. L’installation est neuve, il n'y a pas encore apache ou quoi que ce soit. J'ai installé Bind9 (en fait il y était déjà tongue.gif ). Donc voici ma configuration :

/etc/bind/named.conf.options


options {
directory "/var/cache/bind";
// If there is a firewall between you and nameservers you want
// to talk to, you may need to fix the firewall to allow multiple
// ports to talk. See http://www.kb.cert.org/vuls/id/800113
// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.
// forwarders {
// 0.0.0.0;
// };
auth-nxdomain no; # conform to RFC1035
listen-on-v6 { ::1; };
listen-on { any; };
listen-on port 53 { any; };
allow-recursion { 127.0.0.1; };
};

/etc/bind/named.conf.local


//
// Do any local configuration here
//
// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";
zone "sperec.fr" {
type master;
allow-transfer {217.70.177.40;} ;
file "/etc/bind/db.sperec.fr";
};

/etc/bind/db.sperec.fr


; TTL (Time To Live)
$TTL 604800
; Informations générales
@ IN SOA sperec.fr. ns1.sperec.fr. (
2 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL
;
; Enregistrements du domaine, des sous-domaines et correspondances IP
@ 10800 IN A 91.229.20.94
admin 10800 IN A 91.229.20.94
barbara 10800 IN A 91.229.20.94
imap 10800 IN A 91.229.20.94
irc 10800 IN A 91.229.20.94
mail 10800 IN A 91.229.20.94
minecraft 10800 IN A 91.229.20.94
ns1 10800 IN A 91.229.20.94
popAH 10800 IN A 91.229.20.94
romainluke 10800 IN A 91.229.20.94
smtp 10800 IN A 91.229.20.94
ts 10800 IN A 91.229.20.94
www 10800 IN A 91.229.20.94
ye 10800 IN A 91.229.20.94
@ 10800 IN MX 50 mail.sperec.fr.
@ 10800 IN MX 10 mail.sperec.fr.
@ 10800 IN TXT "google-site-verification=gzpY9uUE0BysinmR3a0xz-ShNwkrq4nwvO4Np9TbNDo"

Et l'AFNIC me répond ceci :

http://puu.sh/Zh3D

Et... Je bloque wink.gif

Merci de vote aide, si vous avez besoin de précision n'hésitez pas smile.gif

Tutur !

Edited by Tutur

Share this post


Link to post
Share on other sites

En fait il manque le principal dans tes infos ...

Tu utilises quoi comme DNS pour la zone sperec.fr ?

Parce que la réponse de gandi le dit bien : c'est ns6.gandi.net qui ne répond pas pour la zone.

Share this post


Link to post
Share on other sites

Ce n'est pas ce que je vois !

ns1.le-hub.net:dan# dig sperec.fr

; <<>> DiG 9.7.3 <<>> sperec.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65262
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 6

;; QUESTION SECTION:
;sperec.fr. IN A

;; ANSWER SECTION:
sperec.fr. 10800 IN A 91.229.20.94

;; AUTHORITY SECTION:
sperec.fr. 10800 IN NS a.dns.gandi.net.
sperec.fr. 10800 IN NS c.dns.gandi.net.
sperec.fr. 10800 IN NS b.dns.gandi.net.

;; ADDITIONAL SECTION:
a.dns.gandi.net. 80465 IN A 173.246.97.2
a.dns.gandi.net. 80465 IN AAAA 2604:3400:a::2
b.dns.gandi.net. 80465 IN A 217.70.184.40
b.dns.gandi.net. 80465 IN AAAA 2001:4b98:b:a::40
c.dns.gandi.net. 80465 IN A 217.70.182.20
c.dns.gandi.net. 80465 IN AAAA 2001:4b98:c:521::20

;; Query time: 21 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Aug 28 11:37:05 2012
;; MSG SIZE rcvd: 236

Share this post


Link to post
Share on other sites

Oui car quand je veux les changer, il me dit qu'il y a une erreur, et donc il fait pas les modifications :/

Share this post


Link to post
Share on other sites

Si tu n'as pas d'info sur l'erreur, vas sur le site de l'Afnic dans Zonecheck->Formulaire complet et entres tes données.

Tu verras quelle est l'erreur et pourras la corriger !

Share this post


Link to post
Share on other sites

Bon donc j'ai des erreurs à gogo en cochant 'Continuer après fatal' :

http://puu.sh/ZDcv

http://puu.sh/ZDcJ

http://puu.sh/ZDcU

http://puu.sh/ZDd3

http://puu.sh/ZDda

http://puu.sh/ZDdB

http://puu.sh/ZDdK

Et la... Je bloque...

Sinon voici l'erreur donné par Gandi :

Zonecheck Error: Le zone-check ne passe pas :

[TEST présence d'un enregistrement SOA]: échec du serveur: (SOA sperec.fr) => ns6.gandi.net/217.70.177.40 ==> ÉCHEC Veuillez donc :

- Verifier votre nouvelle configuration avec zone-check

Pour cela vous pouvez utiliser sur l'url suivante http://www.afnic.fr/outils/zonecheck/zc.cgi?ips1=91.229.20.94&ns0=ns6.gandi.net.&zone=sperec.fr&progress=counter&intro=t&details=t&afnic=&ns1=ns1.sperec.fr.&explain=t

Edited by Tutur

Share this post


Link to post
Share on other sites

Si tu commençais par mettre le nom de ton serveur au lieu de ns1.sperec.fr .... ???

Parce que si la zone sperec.fr n'est pas définie, ns1.sperec.fr ne l'est pas non plus !

Et je ne vois toujours pas où sont définis tes DNS dans ton fichier de zone !!!

Pour moi, ton serveur ne répond pas aux requêtes bind !

ns1.le-hub.net:~# dig sperec.fr @91.229.20.94

; <<>> DiG 9.7.3 <<>> sperec.fr @91.229.20.94
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 10267
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;sperec.fr. IN A

;; Query time: 13 msec
;; SERVER: 91.229.20.94#53(91.229.20.94)
;; WHEN: Tue Aug 28 16:00:50 2012
;; MSG SIZE rcvd: 27

Share this post


Link to post
Share on other sites

Scuse moi je débute avec Bind, et j'ai pas tout compris dans ton message :/

Déjà, la ligne je ne l'est pas, ensuite, je dois mettre où sperec.fr ?

Merci de ton aide,

Sinon oui Bind tourne bien sur mon serveur ;)

Share this post


Link to post
Share on other sites

Le code que j'ai mis dans mon dernier message est celui qui permet d'interroger bind sur ton serveur dédié pour avoir les infos sur la zone sperec.fr !

Donc "dig sperec.fr @91.229.20.94 " fait cette requête.

Et suite à celle-ci je reçois un "SERVFAIL" ! Donc un serveur (celui sur l'IP 91.229.20.94) qui ne répond pas !

Cela confirme donc les erreurs que tu as sur l'Afnic et que tu mentionnes plus haut. Quasiment chaque ligne te donne "echec du serveur ns1.sperec.fr"

Que donne la commande suivante lancée en tant que root sur ton serveur :

netstat -tanpu | grep ":53"

Share this post


Link to post
Share on other sites

Euh ouais, je suppose que c'est pas top ^^

Voici le résultat de la commande :) :


tcp 0 0 91.229.20.94:53 0.0.0.0:* LISTEN 10156/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 10156/named
tcp6 0 0 ::1:53 :::* LISTEN 10156/named
udp 0 0 91.229.20.94:53 0.0.0.0:* 10156/named
udp 0 0 127.0.0.1:53 0.0.0.0:* 10156/named
udp6 0 0 ::1:53 :::* 10156/named

Share this post


Link to post
Share on other sites

Si, cela semble correct !

Et la commande

grep named /var/log/syslog

donne quoi ?

Tu as certainement une erreur quelque part !

Share this post


Link to post
Share on other sites

Une question : juste après l'installation de Debian, as-tu bien lancé ceci :


apt-get update
apt-get dist-upgrade

Parce que l'image de Debian que tu as chargée n'est peut-être pas à jour !

Share this post


Link to post
Share on other sites

La apparemment il y a quelques trucs, mais je suis incapable de déchirer :^^


Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving '117.113.9.2.in-addr.arpa/PTR/IN': 2001:500:13::73#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving '117.113.9.2.in-addr.arpa/PTR/IN': 2001:43f8:110::10#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/A/IN': 2001:500:e::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:500:f::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/A/IN': 2001:500:c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:500:e::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/A/IN': 2001:500:40::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:500:48::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:500:b::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:500:40::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/A/IN': 2001:500:60::30#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.isc.afilias-nst.info/AAAA/IN': 2001:500:1b::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'sns-pb.isc.org/AAAA/IN': 2001:4f8:0:2::19#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.wanadoo.fr/AAAA/IN': 2001:500:2e::2#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.orange.fr/A/IN': 2a00:d78:0:102:193:176:144:6#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.orange.fr/A/IN': 2001:500:2e::2#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns1.orange.fr/AAAA/IN': 2001:678:c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.orange.fr/A/IN': 2001:678:c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.wanadoo.fr/AAAA/IN': 2001:678:c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.orange.fr/A/IN': 2001:67c:1010:11::53#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns1.orange.fr/AAAA/IN': 2001:678:4c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns2.wanadoo.fr/AAAA/IN': 2001:678:4c::1#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns1.orange.fr/AAAA/IN': 2001:67c:1010:11::53#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.isc.afilias-nst.info/A/IN': 2001:500:8::79#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.isc.afilias-nst.info/AAAA/IN': 2001:500:a::79#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.isc.afilias-nst.info/AAAA/IN': 2001:500:6::79#53
Aug 28 09:35:46 srv75 named[10156]: error (network unreachable) resolving 'ns.isc.afilias-nst.info/AAAA/IN': 2001:500:7::79#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving '89.225.23.94.in-addr.arpa/PTR/IN': 2001:500:2e::1#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving '89.225.23.94.in-addr.arpa/PTR/IN': 2001:67c:e0::5#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving '89.225.23.94.in-addr.arpa/PTR/IN': 2001:41d0:1:1986::1#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'a.gtld-servers.net/A/IN': 2001:503:ba3e::2:30#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'c.gtld-servers.net/AAAA/IN': 2001:7fe::53#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'd.gtld-servers.net/A/IN': 2001:7fd::1#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'g.gtld-servers.net/A/IN': 2001:7fd::1#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'h.gtld-servers.net/AAAA/IN': 2001:500:2f::f#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'k.gtld-servers.net/AAAA/IN': 2001:500:1::803f:235#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'k.gtld-servers.net/AAAA/IN': 2001:503:ba3e::2:30#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'd.gtld-servers.net/AAAA/IN': 2001:503:83eb::2:31#53
Aug 28 09:53:33 srv75 named[10156]: error (network unreachable) resolving 'e.gtld-servers.net/AAAA/IN': 2001:503:a83e::2:31#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'h.gtld-servers.net/AAAA/IN': 2001:500:1::803f:235#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'k.gtld-servers.net/AAAA/IN': 2001:500:3::42#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'h.gtld-servers.net/AAAA/IN': 2001:503:c27::2:30#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'k.gtld-servers.net/AAAA/IN': 2001:dc3::35#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'h.gtld-servers.net/AAAA/IN': 2001:7fd::1#53
Aug 28 09:53:34 srv75 named[10156]: error (network unreachable) resolving 'k.gtld-servers.net/AAAA/IN': 2001:503:a83e::2:30#53
Aug 28 10:14:30 srv75 named[10156]: error (network unreachable) resolving '125.163.38.95.in-addr.arpa/PTR/IN': 2001:67c:e0::1#53

Share this post


Link to post
Share on other sites

Et tant qu'on y est, dans le fichier de zone, ajoute ces deux lignes juste après

      604800 )                        ; Negative Cache TTL


sperec.fr. 14400 IN NS ns1.sperec.fr.
sperec.fr. 14400 IN NS ns6.gandi.net.

Share this post


Link to post
Share on other sites

Merci, j'ai relancé l'opération sur gandi, je te donne la réponse dans 10/15min ;)

Encore merci de ton aide.

Share this post


Link to post
Share on other sites

Je pense avoir trouvé ! Bind essaie d'utiliser IPv6 alors que ton serveur n'est pas configuré pour cela.

Donc modifie le fichier /etc/default/bind9 et ajoute à la fin de celui-ci

OPTIONS="-4"

Ensuite relance bind avec

/etc/init.d/bind9 restart

Ton fichier /etc/default/bind9 devrait ressembler à ça :

# run resolvconf?
RESOLVCONF=yes

# startup options for the server
OPTIONS="-u bind -4"

Share this post


Link to post
Share on other sites

Et dis nous ensuite ce que donne la commande

dig sperec.fr

lancée en tant que root sur ton serveur ?

<edité>

C'est bon maintenant , je vois que ton serveur répond :

ns1.le-hub.net:default# dig sperec.fr @91.229.20.94

; <<>> DiG 9.7.3 <<>> sperec.fr @91.229.20.94
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53490
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;sperec.fr. IN A

;; ANSWER SECTION:
sperec.fr. 10800 IN A 91.229.20.94

;; AUTHORITY SECTION:
sperec.fr. 14400 IN NS ns1.sperec.fr.
sperec.fr. 14400 IN NS ns6.gandi.net.

;; ADDITIONAL SECTION:
ns1.sperec.fr. 10800 IN A 91.229.20.94

;; Query time: 13 msec
;; SERVER: 91.229.20.94#53(91.229.20.94)
;; WHEN: Tue Aug 28 17:13:10 2012
;; MSG SIZE rcvd: 104

Assure-toi tout de même d'avoir incrémenté le serial lors de chaque modif du fichier de zone !

Mets plutôt un nombre sous la forme yyyymmddnn avec nn qui s'incrémente à chaque modif !

Donc pour aujourd'hui : 2012082801 , puis 2012082802 etc...

Share this post


Link to post
Share on other sites

J'ai fais tout ce que tu m'a dit smile.gif Et je viens de relancer la demande sur gandi wink.gif

Aussi j'obtient la même choses que toi avec cette commande smile.gif


dig sperec.fr

J'attend et je te dis ça wink.gif

Edited by Tutur

Share this post


Link to post
Share on other sites

On avance on avance ^^

Une nouvelle erreur :

Zonecheck Error: Le zone-check ne passe pas :

f> Le champ 'expire' doit être au moins 7 fois celui du 'refresh' :

La valeur du champ 'expire' est de 2419200 sec, et devrait être 7 : fois plus grande que celle du 'refresh' (604800 sec).

`..... .. .. . . . => ns6.gandi.net/217.70.177.40 ==> ÉCHEC (et 2 avertissement(s))

Veuillez donc : - Verifier votre nouvelle configuration avec zone-check Pour cela vous pouvez utiliser sur l'url suivante http://www.afnic.fr/outils/zonecheck/zc.cgi?ips1=91.229.20.94&ns0=ns6.gandi.net.&zone=sperec.fr&progress=counter&intro=t&details=t&afnic=&ns1=ns1.sperec.fr.&explain=t

Par contre j'ai l'impression que ça vient pas de chez moi --'

Share this post


Link to post
Share on other sites

Si, c'est chez toi !

Edite le fichier de zone (n'oublie pas d'incrémenter le serial)

Tu as les champs expire et refresh au début !

Change le refresh et mets 86400 (ça fait un jour). Tu peux laisser le champ expire tel quel !

Je répète: n'oublie pas le serial !!!

Et ensuite relance bind !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...