Jump to content
Victor21

Installer Webpagetest sur Linux ?

Rate this topic

Recommended Posts

Salut,

J'utilise souvent le service de mesure des performances de https://www.webpagetest.org/

Cet outil est disponible en open source et j'aimerais l'utiliser pour automatiser la surveillance d'un certain nombre de sites.

La procédure décrite pour installer ce qu'ils appellent une "private instance" est ici : https://sites.google.com/a/webpagetest.org/docs/private-instances

Dans les forums j'ai trouvé un exemple "non officiel" pour Linux : https://www.webpagetest.org/forums/showthread.php?tid=13411

 

Ma question est : avez-vous déjà essayé d'installer ce service sur un serveur Linux ? Des retours d'expérience ?

Merci et bonne journée à tous.

Share this post


Link to post
Share on other sites

Bonjour,

 

Il ne faut surtout pas suivre les tutoriels trouvés sur le Net.Tout ce qu'ils feraient, c'est planter complètement l'installation de ton serveur sous Directadmin.

 

Manifestement, personne ici n'a d'expérience de cette instance privée.

 

Dan

 

 

Share this post


Link to post
Share on other sites

Bonjour Dan,

 

Merci pour ta réponse. Effectivement ce sujet ne mobilise pas les foules ! Je vais suivre ton conseil.

 

Bonne journée à toi

 

Victor

Share this post


Link to post
Share on other sites

Je clôture ce post pour signaler que ton serveur tourne maintenant l'interface web de WebPageTest.

 

Il te manque juste une instance privée de test (sur un PC Windows), en suivant par exemple

le tutoriel de cette page: https://www.peterhedenskog.com/blog/2015/07/private-wpt-instance/

ou encore https://calendar.perfplanet.com/2016/automation-of-your-own-webpagetest-private-instances/

ce qui ne devrait prendre que quelques minutes à l'aide du script PowerShell.

 

Dan

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Celinebi
      Bonjour,
      La société pour laquelle je travaille dispose d'un site internet qui a été développé en php et auquel ont été interfacés 2 blogs sous wordpress : la tribu et le mag
      Quand je passe du site au mag, ça va mais quand je passe du site au blog c'est plus lent.
      j'y connais pas grand chose alors si quelqu'un peut me donner quelques pistes. Voici les liens pour tester : 
      -le site : https://www.lucca.fr/
      -le blog tribu : https://www.lucca.fr/blog/
       
      Merci
      Céline
       
    • By SStephane
      Hello,

      J'ai un souci inexplicable (par moi en tout cas) sur une app développée en Symfony2.3.x, je ne récupère pas les variables postées dans mon controller lorsque je déploie en preprod (sous linux), en local, ça ofnctionne (même version de PHP, Windows).

      Voici la méthode controller :
      public function autocompleteAction(){ $request = $this->getRequest(); if($request->getMethod()=='POST'){ $field = $request->request->get('field'); $start = $request->request->get('start'); //.... $rows = $conn->fetchAll($sql); $arr = array('success' => true,'response' =>$rows); $response = new Response(json_encode($arr) ); $response->headers->set('Content-type','application/json'); return $response; }} Le truc qui fait merder est que les variables $field & $start sont vides (en preprod, ça fonctionne en local), comme si $request->request->get('field') renvoyait une chaîne vide.

      Les variables sont bien postées (vérifié) et l'objet request de symfony semble contenir ces parametres, ce qui me surprend :
      ["request"]=> object(Symfony\Component\HttpFoundation\ParameterBag)#7 (1) { ["parameters":protected]=> array(2) { ["field"]=> string(4) "name" ["start"]=> string(2) "pl" } }
    • By Dadou
      Aujourd'hui c'était la sortie de Hardy Heron, je pensais attendre ce week-end pour l'installer, mais un fichu spyware sur mon windows XP m'en a dissuadé.

      Du coup, je glisse le CD de Ubuntu dans mon lecteur, et demarre la machine dessus, il me propose plusieurs choix, mais je prends directement celui : Installer, pas de dual boot, pas de live CD, pas de regrets, Bye Windows, on s'entendaient bien, mais parfois tu as besoins d'un bon dégraissage.

      Un peu de mal à reprendre mes marque, cela ne fait pas longtemps que je joue avec linux, mais j'arrive petit à petit à m'en sortir, en tout cas une chose appréciable, je n'ai pas besoin de jouer avec la recherche de drivers.
×
×
  • Create New...