Jump to content
Sign in to follow this  
Bocar

Icone de Site

Rate this topic

Recommended Posts

Pour avoir l'icone de son site ds les navigateurs et dans les Favoris:

Je mets le favicon.ico ds le dossier www de mon site mais il n'y a aucun effet :fou:

Je m'y prends mal ?

Merci B)

Edited by Modibo

Share this post


Link to post
Share on other sites

Salut,

Certains navigateurs comme Omniweb ou Firefox vont chercher automatiquement une image &quot;http://serveur/favicon.ico". Pour les autres il faut leur préciser avec "<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />" ;)

Share this post


Link to post
Share on other sites

<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />

En déposant l'image à la racine de ton site et en utilisant la syntaxe proposée par Dudu, tu devrais la voir apparaître (quelques virils crtl+f5 auront raison d'une cache récalcitrantes).

Share this post


Link to post
Share on other sites

J'ai mis le code en dessous des metas entre les balises <head> et </head> !

L'icone est dans le dossier www

J'ai essayé avec l'adresse du nom de domaine, et l'adresse de l'hébergeur...

Mais toujours rien ! :huh:

Share this post


Link to post
Share on other sites

On peut voir un peu de code ? B)

Share this post


Link to post
Share on other sites
J'ai mis le code en dessous des metas entre les balises <head> et </head> !

L'icone est dans le dossier www

<{POST_SNAPBACK}>

à mon avis Modibo utilise IE comme navigateur.

pour l'exemple, avec FFox ou Mozilla je vois l'icone du hub

alors que sous IE ca ne s'affiche pas.

de même que le papillon de msnsearch ne s'affiche pas sous IE.

j'ai beau faire ctrl+F5, je ne vois pas le papillon. :D

Share this post


Link to post
Share on other sites

J'utilise Mozilla suis pas fou :fou:

Moi aussi je vois l'icone de Hub ici...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
<html xml:lang="en" lang="en" xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>......
-....
-...
-..
-.
<META http-equiv="Content-Script-Type" CONTENT="text/javascript">
<LINK href="main.css" type=text/css rel=stylesheet>
<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
<% GENERATOR %>
<% CSS %>
<% JAVASCRIPT %>

<script language="JavaScript">
<!--

// Anti clic droit par www.aidoforum.com

function noclic(clic)
.....
....
...
..
</head>

Edited by Modibo

Share this post


Link to post
Share on other sites

Pour certains navigateurs je crois qu'il faut avoir le site en favori, couper son navigateur et revenir sur le site

Share this post


Link to post
Share on other sites
Pour certains navigateurs je crois qu'il faut avoir le site en favori, couper son navigateur et revenir sur le site

<{POST_SNAPBACK}>

j'ai essayé de mettre la page index du hub en favori sous IE, effectivement l'icone s'affiche. mais quand je passe à une autre page, l'icone disparaît . :fou:

alors que sous FF : aucun problème, on a l'icone à chaque page.

vous ne mettez pas chaque page ou chaque post en favori quand même sous ie ?

Share this post


Link to post
Share on other sites

Pour IE, il faut la page en favori et on a l'icone que sur les pages où figure le tag

<link rel="shortcut icon".... me semble-t-il. J avais fait l'essai pour un de mes sites

C'est IE :lol:

Share this post


Link to post
Share on other sites

Exactly Dudu, t'es un chef!

Donc quand jepasses parl'adresse de OVH (la vrai) ça marche bien !

Maintenant manque plus qu'à régler deux problèmes surmon Sites, en relation avec mon nom de domaine B)

Encore Merci Dudu

Share this post


Link to post
Share on other sites
Exactly Dudu, t'es un chef!

Donc quand jepasses parl'adresse de OVH (la vrai) ça marche bien !

Maintenant manque plus qu'à régler deux problèmes surmon Sites, en relation avec mon nom de domaine B)

Encore Merci Dudu

Houla, il y a un problème sur ton clavier avec les touches "Espace" et "Majuscule" on dirait :huh:

Que veux-tu dire par "l'adresse d'OVH (la vraie)" il y a une autre adresse pour accéder à ton site et çà ne marche pas avec celle-là ?

Je n'ai pas bien compris en fait si ton problème était réglé ou non :unsure:

Share this post


Link to post
Share on other sites

sorry mon Espace flaire, et qq touches aussi :fou:

Bah y'a l'adresse de mon domaine, http://www.soccers.fr pris chez oxyd

et celle à l'hébergement http://60gp.ovh.net/~soccers/ de chez OVH

Celle-ci, de OVH, est doté du Favicon, pas la première !

D'ailleurs j'ai deux trois truc à régler avec comme je l'ai dit

Le faviconmarche pas avec IE !

Mercii Microsoft encore :hypocrite:

Edited by Modibo

Share this post


Link to post
Share on other sites

http://www.soccers.fr/favicon.ico

Not Found
The requested URL /favicon.ico was not found on this server.



Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.27 Server at soccers.fr Port 80

C'est peut-être pour çà ;)

Visiblement soccers.fr n'est qu'une redirection, donc rien n'est hebergé dessus, donc pas de favicon...

çà me semble logique, ce sont les aléas des redirections par frame

Share this post


Link to post
Share on other sites

Impossible de changer ça ?

C'est pour ça que toutes mes pages se nommes Soccers.fr alors :(

Share this post


Link to post
Share on other sites

Cette page, je crois, vous permettra de comprendre pourquoi IE fait des siennes : http://www.xhtml.net/xhtmlcss/favicon

En gros, il existe deux méthodes pour intégrer un favicon, la méthode standard et la méthode propriétaire. Comme Dudu a été assez gentil pour nous présenter la méthode conforme et que MSIE est assez égal à lui-même pour ne comprendre que la méthode propriétaire, il est normal que de bien coder le favicon ne marche pas avec IE. :fou:

Si on respecte les standards

Vous devez mettre le lien suivant dans votre page entre les balises <head> et </head>.

<link rel="icon" type="image/png" href="/favicon.png" />

Remarquez le type qui contient le type ou Mime Type de l'image. Voici les types que vous pouvez utiliser pour les 4 classiques :

    * image/png: image PNG.

    * image/gif: image GIF.

    * image/jpeg: image JPEG.

    * image/x-icon: image de type icon, attention ce format n'est pas un format standard.

Si on ne respecte pas les standards

Et vous serez obligés de faire cela si vous voulez que Internet Explorer puisse utiliser l'icône.

<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />

Notez l'utilisation du type shortcut icon à la place de icon et l'obligation d'utiliser une image au format ICO.

Share this post


Link to post
Share on other sites

Oh, erreur !

Je réalise que c'est tout le contraire... la méthode de Dudu était la propriétaire, pas la conforme... :o

Qu'à cela ne tienne, l'information dispensée par Loïc sur XHTML.net est bel et bien la bonne. :)

Share this post


Link to post
Share on other sites

Merci, c'est réglé pour le Favicon on dirait, il s'affiche même pour www.soccers.fr :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...