Jump to content
Sign in to follow this  
Ernestine

Internet explorer localhost sans internet

Recommended Posts

Bonjour,

Sur mon PC portable, j'ai installé un serveur Apache avec tout le reste (php, mysql, etc) afin de travailler en local. J'accède donc à mes sites de test par des noms de domaines définis dans le fichier HOSTS et des hôtes virtuels configurés dans le fichier de conf d'Apache.

Il m'arrive très souvent de devoir travailler sans connexion internet. Le problème : si je ne suis pas connectée à internet et que je tente d'accéder à un site local, Internet Explorer m'affiche une vieille petite fenêtre avec un double choix : "Travailler hors connexion" ou bien "Se connecter à internet". Evidemment la deuxième option est à éliminer (puisque dans ces moments-là je n'ai pas de connexion), mais si je coche "Travailler hors connexion", alors Internet Explorer n'essaie même pas de se connecter à mon serveur local et m'affiche une page blanche sous prétexte que je ne suis pas connectée à Internet !

Tout se passe très bien avec tous les autres navigateurs (Chrome, Firefox, et compagnie), seul internet explorer refuse de me laisser accéder à mon serveur local sous prétexte que je n'ai pas de connexion internet. Du coup je ne peux pas effectuer les traditionnelles petites vérifications incontournables sur IE. Par ailleurs ce problème est récent : ça me le fait seulement depuis une dizaine de jours.

Je suppose que c'est un paramétrage à faire quelque part, mais lequel ? Merci d'avance.

PS : je suis sous Windows 7 avec IE9.

Share this post


Link to post
Share on other sites

je n'utilise presque pas IE, mais peut-être en le passant en rétrocompatibilité IE8 ? Je ne saurais trop dire, ce n'est qu'une suggestion.

Share this post


Link to post
Share on other sites

Merci Aenoa mais c'est au niveau de la connexion qu'était le problème ;)

J'ai fini par trouver en bidouillant partout dans les options : il fallait aller dans les options Internet dans l'onglet Connexions, puis sur Paramètres réseau et cocher la case "utiliser un serveur proxy pour votre réseau local".

Je ne sais pas pourquoi ça marche, mais ça marche :)

Share this post


Link to post
Share on other sites

Je ne sais pas pourquoi ça marche, mais ça marche :)

Cela illustre bien deuxième partie de la phrase d'Enstein que j'ai dans ma signature ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...