Jump to content
Sign in to follow this  
silexian

Quand les gens utilisent Internet Explorer 1.0 !

Recommended Posts

Quand les gens utilisent Internet Explorer 1.0 !

Où j'hallucine qd je regarde les stats...

Bonjour à tous !

Et bien voilà. Etant bien gâté par la nature (Windows XP SP2, FireFox 1.04, et tout ce qu'il faut ailleurs... lol), je me rends compte que bcp de personnes ne suivent pas au niveau du matériel et du logiciel.

Concrètement, je viens de faire le compte de 7 mois d'activité de mon site, et je me suis aperçu d'une chose étrange en faisant la somme des statistiques des navigateurs de mes visiteurs....

Si IE6 (66%) et Firefox 0.9+ (19%) sont bien représentés (soit 85% de visiteurs ayant un navigateur à jour de 2004/2005), il y a une FORTE proportion d'anciennes versions de :

IE 4 : 4,12%

IE 5 : 2,16%

IE 5.5 : 1,27%

Mozilla 2002 à 2004 / Netscape 6 à 7 : 2,18%

ce qui fait tout de même près de 10 % des gens qui ont de vieux voire de TRES VIEUX navigateurs qui ne supportent ni le javascript de ce millénaire, ni le CSS, ni le HTML récent (norme W3C je sais plus laquelle), ni le DHTML évidemment......

Que dois je faire ? Télécharger IE 4 5 et 5.5 afin de tester mon site? ou leur interdire/avertir à l'entrée du site [si qq1 a un script tout prêt ....] ?

Laurent

Share this post


Link to post
Share on other sites

Salut,

"interdire" l'accès à un site, parceque l'utilisateur utilise un "ancien" naviguateur, je ne trouve pas ça trés cool :boude:

Imagine que l'on te refuse l'accès aux forums (de n'importe quel site) sous pretexte que tu utilise une bande passante bas/moyen débit ??

Je te conseille simplement d'afficher un message pour ces dites personnes, afin de les invités à télécharger un naviguateur plus récent ; (tu peut leurs proposé un lien en accès direct vers un navigateur libre (sans aucune pub:firefox).

N'oublie pas qu'Internet doit rester un outil de communication utilisable par et pour TOUT le monde;

;)

@+ oxyd-x

Edited by oxyd-x

Share this post


Link to post
Share on other sites

Bonjour,

Je pense que tu dois faire en sorte que ton site fonctionne pour la majorité et qu'il profite des fonctionnalités apportées depuis IE4...

Tu vas pas pénaliser 90% de tes visiteurs pour les 10% qui restent sous d'anciennes versions de leur explorer. C'est à eux de migrer la version de leur IE et surtout pas à toi de limiter ton site pour qu'il fonctionne sous un navigateur "prehistorique".

Share this post


Link to post
Share on other sites

Merci beaucoup nicolas, oxyd & Dash.

D'une part je vais faire un message pour ceux qui ont un navigateur ancien (migrer vers IE 6 ou Firefox ).

D'autre part, je vais tenter de me conformer à la norme W3C, car il y a pas mal d'erreur vis à vis de la norme ;)... du boulot.

merci Dash pour ces liens... je viens de télécharger IE 4 et NCSA Mosaic (celui là c'est pour rigoler et pour voir les sites actuels en général)... Ben graphiquement ça va, mais effectivement, tout ce qui est javascript, ça passe pas vraiment. DOnc impossible de valider un questionnaire qui fait appel à du javascript :)

Laurent

Share this post


Link to post
Share on other sites

Es-tu sûr qu'ils utilisent un ancien navigateur ?

Il y a quantité de raisons de changer le type de navigateurs lorsque l'on navigue.

Un exemple ?

Un moteur célèbre, que l'on nommera xxx, passe parfois sur les sites, avec un 'USER_AGENT' différent, qu'il 'pioche' dans des stats.

Autrement dit, il utilise des 'types de navigateurs', qui ne sont pas forcément d'actualité.

L'intéret ? Regarder si le site affiche bien la même chose lorsque c'est le 'crawler', que quand c'est un 'utilisateur normal'.

Tu peux jeter un oeil à l'adresse IP de ces personnes qui utilisent d'anciens navigateurs. Tu serais surpris de retrouver de 'grosses boites', qui n'ont rien de très ancien.

anonymus.

Share this post


Link to post
Share on other sites

Salut,

Qui te dit que ce n'est pas ton logiciel de stats qui délire ?

Encore aujourd'hui je suis tombé sur un site qui à défaut de contenu a voulu m'afficher un message du type "vous être l'adresse IP xxx.xxx.xxx.xxx et votre navigateur est NETSCAPE!!!"

Le problème c'est que mon navigateur n'est pas Netscape :D Il n'a même rien à voir avec.

À mon avis, regarde dans tes logs les User-Agent concernés et décrypte-les sans l'aide d'un logiciel ;)

+ les IPs comme dit Anonymus

Télécharger Mosaïc ne te servira pas à grand-chose ;)

Que dois je faire ? Télécharger IE 4 5 et 5.5 afin de tester mon site?

Tu peux déclarer 2 feuilles CSS. Une première qui ne contient que des règles de bases compréhensibles par les vieux navigateurs. Cette CSS va permettre d'afficher le site à peu près correctement: lisible mais sans fioritures. La deuxième CSS contiendra tous les codes modernes ignorés par les mêmes navigateurs anciens.

Et pour lancer la 2ème CSS, tu fais appel à @import() qui n'est reconnu que par des navigateurs récents ;)

ou leur interdire/avertir à l'entrée du site [si qq1 a un script tout prêt ....] ?

Il n'y a rien à interdire à personne.

Moi qui suis sur Mac, tu aimerais que je mette un mot à l'entrée de mes sites en disant "vous utilisez un OS qui n'est pas sécurisé, veuillez upgrader vers quelque chose de moderne" ?

Tu vas me répondre "non je n'aimerais pas, mais tu ne peux pas faire çà parce qu'une majorité de gens utilisent Windows"

Et je te réponds que beaucoup ont fait çà pour Firefox contre IE alors qu'une majorité d'internautes utilisaient IE ;)

Ce n'est sympa pour personne de se faire refuser un accès au site. D'autant qu'un utilisateur d'OS exotique comme SunOS ou Solaris n'aura pas forcément la possibilité de choisir un navigateur plus perfectionné que celui qu'il utilise. Le web est fait pour communiquer, pas pour critiquer les choix informatiques des uns ou des autres. Au webmaster de s'adapter.

Pour info: "Quiconque appose sur une page du web un logo du type : Cette page est optimisée pour le navigateur X est quelqu'un qui semble souhaiter revenir à l'époque préhistorique d'avant le web, lorsque l'on avait très peu de chances de pouvoir lire un document écrit sur un autre ordinateur, un autre traitement de texte, ou un autre réseau."

-- Tim Berners-Lee dans Technology Review, Juillet 1996

(Tim Berners-lee est l'inventeur du web)

Share this post


Link to post
Share on other sites
Mozilla 2002 à 2004 / Netscape 6 à 7 : 2,18%

<{POST_SNAPBACK}>

Bon, 2004 c'est pas si loin que ça... 8 mois ;)

Et puis Netscape 7 n'est pas si préhistorique que ça (la 7.2 est sortie je pense il y a environ 1 an, peu après Mozilla 1.7)

Il faut aussi savoir que IE 5.5 se comporte presque comme IE6 la plupart du temps (je crois que la différence la plus importante de ce dernier est le doctype sniffing, ce qui n'est pas rien je te l'accorde). IE 5 est un peu plus loin...

merci Dash pour ces liens... je viens de télécharger IE 4 et NCSA Mosaic (celui là c'est pour rigoler et pour voir les sites actuels en général)... Ben graphiquement ça va
J'en déduis que tu n'utilise pas de CSS ? Parce qu'avec CSS il est facile de faire que la page s'affiche "brute" avec les anciens navigateurs, ce qui permet, si elle est bien construite, de conserver une parfaite lisibilité ;)

mais effectivement, tout ce qui est javascript, ça passe pas vraiment. DOnc impossible de valider un questionnaire qui fait appel à du javascript :)

<{POST_SNAPBACK}>

D'où la nécessité de ne pas faire dépendre quoi que ce soit du javascript, chose bien trop souvent oubliée par les webmasters.

Il faut savoir que 10% des internautes ont JS désactive :huh: (source, milieu de la page environ, autre source).

Share this post


Link to post
Share on other sites

bonjour

Effectivement, mozilla 2004/Netscape 7 n'est pas très vieux, je suis allé un peu vite ! Mais vu la somme de navigateurs à base de Gecko présents dans les stats, j'ai pensé que c'était à classer parmis les "45 Tours et 33 Tours d'internet" (lol).

J'utilise des CSS, mais je voulais dire que "ça pouvait aller" en utilisant IE 4, dans le sens où même si c'était pas traité, on arrivait à avoir une interface presque fidèle (mais pas fonctionnelle).

Par contre pour le Javascript, je suis fortement emm**dé. La validation de formulaire passe par du javascript, et impossible de passer outre :S ... et je ne parle même pas des cookies :S ... Une petite réflexion s'impose.

Share this post


Link to post
Share on other sites

Je suis tout a fait d'accord avec ce qui a ete dit : ce n'est pas au concepteur de sites de decider ce que doivent utiliser les visiteurs (specialement si la reference c'est XP SP2 :fou: ).

Ben ouai, je surfe a la maison sur un Sun sous Solaris 8 avec Netscape 7 :lol: (paske j'ai la fleme d'installer Mozilla ou FireFox) et je peux t'assurer que 99% des sites passent correctement.

Le pourcentage restant provient de site M$-IE only ... tant pis pour eux :P

Par contre pour le Javascript, je suis fortement emm**dé. La validation de formulaire passe par du javascript, et impossible de passer outre :S ... et je ne parle même pas des cookies :S ... Une petite réflexion s'impose.

<{POST_SNAPBACK}>

Oula, ca fait bien longtemps que je n'utilise plus le JS pour valider mes formulaires si ce n'est pour de simples testes (genre, est-ce que la date est valide, ...).

De toute facon, tous les arguments sont revalides cote serveurs pour des problemes evidents de securite.

Ce qui fait que le site est generalement navigable aussi sans JS.

Edited by destroyedlolo

Share this post


Link to post
Share on other sites

Bonjour,

Par contre pour le Javascript, je suis fortement emm**dé. La validation de formulaire passe par du javascript, et impossible de passer outre :S ... et je ne parle même pas des cookies :S ... Une petite réflexion s'impose.

<{POST_SNAPBACK}>

Cet article, Bien valider ses formulaires avec Javascript, pourrait t'aider dans ta réflexion B)

Share this post


Link to post
Share on other sites

Pour compléter ce qui disait Anonymus, je dirais qu'il y a aussi les captureurs de sites qui quelquefois revoient un user-agent ras du bitume (genre IE3 ou IE4).

Share this post


Link to post
Share on other sites
Effectivement, mozilla 2004/Netscape 7  n'est pas très vieux, je suis allé un peu vite ! Mais vu la somme de navigateurs à base de Gecko présents dans les stats, j'ai pensé que c'était à classer parmis les "45 Tours et 33 Tours d'internet"  (lol).

<{POST_SNAPBACK}>

C'est vrai que les navigateurs Gecko sont très diversifiés, surement le côté "Open Source" qui permets à chacun d'en faire ce qu'il veut, ainsi que les mises à jour fréquentes...

Mais au final, ce qui compte c'est ce qu'il y a sous le capot, et dans ce cas ce qui compte c'est le "rv:XXXX" qui indique le numéro de version (de Gecko, donc de Mozilla).

Par exemple la dernière version de Firefox est "rv:1.7.11". Avec ça tu peux savoir avec précision quelle est la "vraie" version utilisée, Netscape 7.2 est "rv:1.7.2", la 7.1 doit correspondre à Mozilla rv:1.4 etc. (Ensuite tu peux comparer avec les dates de sortie des Mozilla correspondants, si tu tiens à avoir une estimation chiffrée.). En tous les cas cette distinction est bien plus représentative de ce que les gens ont vraiment... la carrosserie est nettement moins importante (pour le webmaster que tu es) ;)

Je doute que tu trouves encore beaucoup de Netscape 6 (rv:0.XXX), dans ce cas ça accréditerait la thèse d'Anonymus :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...